Minggu, Januari 16, 2011

ARP dan RARP

sebuah protokol dalam TCP/IP Protocol Suite yang bertanggungjawab dalam melakukan resolusi alamat IP ke dalam alamat Media Access Control (MAC Address). ARP didefinisikan di dalam RFC 826

ARP berasosiasi antara alamat fisik (MAC address) dan alamat IP. Pada LAN, setiap device, host, station dll diidentifikasi dalam bentuk alamat fisik yang didapat dari NIC.

Setiap host atau router yang ingin mengetahui alamat fisik daripada host atau router yang terletak dalam jaringan lokal yang sama akan mengirim paket query ARP secara broadcast, sehingga seluruh host atau router yang berada pada jaringan lokal akan menerima paket query tersebut. Kemudian setiap router atau host yang menerima paket query dari salah satu host atau router yang mengirim maka akan diproses hanya oleh host atau router yang memiliki IP yang terdapat dalam paket query ARP. Host yang menerima respons akan mengirim balik kepada pengirim query yang berisi paket berupa informasi alamat IP dan alamat fisik.

itu pengertian yang jelasnya, klo mau simpel begini :
host atau router yang mau tahu alamat fisik dari host atau router di dalam jaringan lokal yang sama mengirimkan paket query secara keseluruhan di dalam jaringan itu.Semua dapat querynya tapi hanya host atau router yang berwenang (lewat IP) yang bisa membalas balik query ARPnya.respon baliknya yaitu paket berupa alamat IP dan alamt fisik.


Ketika sebuah aplikasi yang mendukung teknologi protokol jaringan TCP/IP mencoba untuk mengakses sebuah host TCP/IP dengan menggunakan alamat IP, maka alamat IP yang dimiliki oleh host yang dituju harus diterjemahkan terlebih dahulu ke dalam MAC Address agar frame-frame data dapat diteruskan ke tujuan dan diletakkan di atas media transmisi (kabel, radio, atau cahaya), setelah diproses terlebih dahulu oleh Network Interface Card (NIC). Hal ini dikarenakan NIC beroperasi dalam lapisan fisik dan lapisan data-link pada tujuh lapis model referensi OSI dan menggunakan alamat fisik daripada menggunakan alamat logis (seperti halnya alamat IP atau nama NetBIOS) untuk melakukan komunikasi data dalam jaringan.


Jika memang alamat yang dituju berada di luar jaringan lokal, maka ARP akan mencoba untuk mendapatkan MAC address dari antarmuka router lokal yang menghubungkan jaringan lokal ke luar jaringan (di mana komputer yang dituju berada).

Sekarang RARP
Silakan

Reverse Address Resolution Protocol (RARP) adalah protokol jaringan usang komputer yang digunakan oleh komputer host untuk meminta perusahaan Internet Protocol ( IPv4 ) alamat dari suatu host administrasi, ketika telah yang tersedia Link Layer atau alamat perangkat keras, seperti MAC address.

Ia telah dianggap usang oleh Bootstrap Protocol (BOOTP) dan modern Dynamic Host Configuration Protocol (DHCP), yang mendukung kedua fitur yang jauh lebih besar daripada yang ditetapkan RARP.RARP membutuhkan satu atau lebih host server untuk memelihara database pemetaan Link Layer alamat protokol masing-masing alamat mereka. Media Access Control (MAC) alamat yang diperlukan untuk secara individual dikonfigurasi pada server oleh administrator.RARP terbatas untuk melayani hanya alamat IP .

Reverse ARP berbeda dari Inverse Address Resolution Protocol (InARP) dijelaskan dalam RFC 2390 , yang dirancang untuk mendapatkan alamat IP yang terkait dengan MAC address host lain.Sesungguhnya RARP didisain untuk memecahkan masalah mapping alamat dalam sebuah mesin/komputer di mana mesin/komputer mengetahui alamat fisiknya namun tidak mengetahui alamat logikanya.

Cara kerja RARP ini terjadi pada saat mesin seperti komputer atau router yang baru bergabung dalam jaringan lokal, kebanyakan tipe mesin yang menerapkan RARP adalah mesin yang diskless, atau tidak mempunyai aplikasi program dalam disk. RARP kemudian memberikan request secara broadcast di jaringan lokal. Mesin yang lain pada jaringan lokal yang mengetahui semua seluruh alamat IP akan akan meresponsnya dengan RARP reply secara unicast. Sebagai catatan, mesin yang merequest harus menjalankan program klien RARP, sedangkan mesin yang merespons harus menjalankan program server RARP.


Terus apa bedanya ARP dengan RARP jika begitu?
nah bedanya dari sini:

ARP
mencari alamat logika (IP) dari alamat fisik dengan mengirimkan paket query ke semua jaringan lokal, yang ditujulah yang akan memberikan balasannya kepada sang pengirim.
RARP
mencari hal yang sama dengan mengirimkan request ke dalam jaringan lokal, hos atau router yang memiliki informasi tentang IP tersebut lantas membalas RARP reply secara unicast.yah klo hostnya mau jawab ya pake program Server RARP dan yang meminta memakai program Klien RARP jadi agak ribet karena memang protokol lama.


terima kasih telah membaca.

Bootstrap (BOOTP)

kali ini kita membahas tentang BOOTP atau bootstrap

silakan


BOOTP berupa konsep protocol standart. Statusnya dianjurkan. Spesifikasi BOOTP
dapat ditemukan pada RFC 951 - Bootstrap Protocol and RFC 1497 - BOOTP Vendor
Information Extensions.

LAN memungkinkan host tanpa harddisk sebagai workstation, router, terminal
concentrator dan masih banyak lagi. Host tanpa harddisk membutuhkan mekanisme untuk
boot dengan di-remote melalui sebuah jaringan. BOOTP protocol digunakan untuk me-
remote booting melalui jaringan IP. BOOTP memperbolehkan protocol IP minimal
sehingga tidak mengganggu informasi konfigurasi yang tidak melakukan apa-apa, biasanya
disimpan di ROM, untuk mendapatkan informasi yang cukup untuk memulai proses
download dengan menggunakan kode boot yang dibutuhkan. BOOTP tidak mendefinisikan
cara untuk men-download selesai, tetapi proses ini biasanya menggunakan TFTP
sebagaimana dideskripsikan RFC 906 – Bootstrap loading menggunakan TFTP.

BOOTP memiliki kegunaan yang sama dengan DHCP, hanya BOOTP didesain
untuk manual pre-configuration dari informasi host di dalam suatu server database. BOOTP
dan DHCP didesain agar bisa route ke jaringan.
  • Kelebihan BOOTP
Bootp memiliki keunggulan antara lain:

- Nga perlu Harddisk, karena ada ethernet dan atau BOOT lan.
- punya log file sehingga saat terjadi oerror bisa dilihat di file itu.
  • Kelemahan BOOTP
Bootp memiliki kelemahan sebagai berikut:

- Haruss setting manual jadi resiko rusak jadi besar.
- Karena pake UDP, pengiriman pesan kurang nagus.
- OS jaman sekrang jarang memasukkan Bootstrap ke dalam sistemnya (yah mungkin buat OS jadul doang)

referensi volkshymne.blogspot.com (morto nuwun om)

yah cukup sekian bahasannya, biasa pakai bahasa santai.

Bootstrap (BOOTP)

Apple Talk (protokol di machintosh)

Assalamualaikum

yah kali ini kita membahas tentang Apple talk, mohon diunjuk mawon.
Apple Talk
ialah perangkat protokol pada Machintosh, protokol ini banyak melibatkan protokol lain yang saling terpadu satu sama lain.Dengan kata lain, protokol ini hanya untuk komputer machintosh.

dengan filosofi mereka bahawa machintosh itu simpel, maka protokol ini di hidden dari user agar tak ketahuan (biar keliatan praktis)

beberapa perangkat protokol yang ikut nimbrung di apple talk antara lain:

  • AppleTalk Data Stream Protocol (ADSP)
Bertugas sebagai pemantau aliran data, pengawasan data antara dua komputer berada di protokol ini.
  • AplleTalk File Protocol (AFP)
Berfungsi untuk menangani file, yah seperti read-only atau hidden itulah protokol ini ditugaskan.
  • AppleTalk Session Protocol (ASP)
protokol yang memeriksa pesan-pesan dalam bentuk bagian-bagian ini bertugas untuk mengecek apakah sudah lengkap dan validkah sebuah pesan tersebut dari bagian-bagian pesan yang ada.
  • AppleTalk Transaction Protocol (ATP)
mengecek keakuratan pesan yang dikirim ke jaringan.
  • Echo Protocol (EP)
protokol pemberi pesan bahwa pesan telah tersampaikan ini juga bertugas untuk memberitahukan bahwa pesan dikirim secara lengkap, pemberitahuan informasi yang telat, dan mengecek lalu lintas agar pesan dapat dikrim secara maksimum.
  • Name Binding Protocol (NBP)
Penerjemah node pada jaringan yang didefinisi user ke dalam sebuah alamat.
  • Page Description Language (PDL)
Himpunan fungsi yang digunakan oleh printer untuk mengontrol pemformatan teks pada kertas.
  • Routing Table Maintenance Protocol (RTMP)
Memantau lokasi node pada jaringan dan memelihara data base hubungan antara node-node tersebut. Apabila satu node mengalami kegagalan, RTMP dapat menetapkan rute alternatif.
  • Zone Information Protocol (ZIP)
Menganalisis konfigurasi jaringan dan himpunan alamat device ke dalam kelompok, atau zone guna menghasilkan akses yang efisien.

nah kira-kira cukup sudah untuk protokol apple talk.